Cannot purchase anything from the store


Customer Service


Been having this issue for a while, but I cannot purchase anything. When i go to the final page of checkout to purchase an item, the place order button refreshes the page, spreads the text out, then does nothing. I want to purchase your PDF's as this seems to be the only way I can have them in non-book form, but I can't. I've tried going through the forums to see what the issue is, and the fixes provided have not worked.

Paizo Employee Customer Service Representative

Hello Philip,

I believe I have resolved the issue. While this is a silly thing, the system cares about the shipping address even on digital orders. You had an address which only had your name filled in. This caused the system to think that it was missing required field and would not submit. I have attached a complete address as the shipping address and deleted the address that just contains your name to avoid this from happening again in the future.

The order is still in your cart, and should submit successfully whenever you are ready. If you have any further questions or concerns, please let us know. Thank you!

Community / Forums / Paizo / Customer Service / Cannot purchase anything from the store All Messageboards

Want to post a reply? Sign in.