Nova not showing


Starfinder Society

51 to 55 of 55 << first < prev | 1 | 2 | next > last >>
Acquisitives 2/5 ⦵⦵

Mark Q. McSlade wrote:
Tineke Bolleman wrote:
Damanta wrote:

Mine seems to have vanished.

Edit: looks like 4 of the 5 sessions of Into the Unknown I ran are not being counted, as they have some kind of warning that I ran it before.

I have those too. Its a general warning and should not affect a game being counted.

I do now have 5 novas showing op on my GM tab, did not have that before.

I have a similar problem. I have 5 Novas listed in my profile but only one is showing up on my card. I should have two since I now have 30 tables completed.

Any idea when this can be corrected/fixed?

Thanks.

Fixed! Yeah!

Thanks!

Liberty's Edge 5/5 Venture-Lieutenant, Alaska—Anchorage aka Dragnmoon

My First Nova does not seem to be showing, maybe I need to post?

5/5 ⦵⦵⦵ Venture-Captain, Germany—Rhein-Main aka GreyYeti

I had the same problem with my third nova.

I had to wait until i got 61 tables for it show up.

2/5 ⦵⦵

Nova Check...

Edit: mine are correct.

Liberty's Edge 3/5 Venture-Captain, Nebraska—Omaha

I have found that it can take a little bit for the star/novas to show up.

51 to 55 of 55 << first < prev | 1 | 2 | next > last >>
Community / Forums / Organized Play / Starfinder Society / Nova not showing All Messageboards

Want to post a reply? Sign in.