Paizo Forum Tools (Firefox / Chrome Browser Extension)


Online Campaigns General Discussion

351 to 391 of 391 << first < prev | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | next > last >>
Silver Crusade

Actually, never mind, I found a way. Pale Moon has an extension that is a list of old Firefox extensions and download links for them.


Glad you were able to find that — you can always download the latest version from the "Releases" page of the Github project.


Hi Oladon,

Campaign tools stopped working mysteriously a few days ago. Anyone else noticed this?

Liberty's Edge

Pathfinder Adventure Path, Rulebook, Starfinder Roleplaying Game Subscriber

I'm not having any issues, AFAICT. Alias sorting and new post highlighting still work.


Works fine for me on latest production Firefox build.


Mine's still working good here on Chrome.


I think this happens every time I clear my cache / cookies. However the extension is still activated in the settings area... anyone knows how to resolve this? PS: I'm using Chrome as well.


If you cleared your cache, make sure to go back to your campaigns page so the extension can re-sync.


GM PDK wrote:
I think this happens every time I clear my cache / cookies. However the extension is still activated in the settings area... anyone knows how to resolve this? PS: I'm using Chrome as well.

Yep, what Enchanter Tim said. Clearing your cache in most browsers also clears localStorage, which is what the extension uses to save your games and settings.

There's an item on my list to switch that over to using the various in-browser preference systems, but I haven't gotten to it yet...


The weird thing is that reloading the extension has installed it successfully on the 'Alias' tab but not on the 'Campaign' tab...


Additional data point: I just downloaded Mozilla Firefox browser and I'm experiencing the same problem, i.e.:

--> Campaign tools only rearranges the Aliases but not the Campaigns. Is there a setting within the Paizo website which deactivates extensions on the Campaigns page? could I have too many campaigns?


2 people marked this as a favorite.

Ok, I found the bug:

--> When you have a campaign without a Gameplay thread it essentially deactivates campaign tools for the campaigns tab... (I had one that was still in the Recruitment stage only, with no associated Gameplay page)

I created a Gameplay thread for that one, and it now works normally, both in Chrome and Firefox.

Yay!

GM PDK


2 people marked this as a favorite.

Huh! Nice find, PDK — that's a weird bug, but with the information you've provided it should be relatively easy to fix.

Thanks for your help!


Pathfinder Card Game Subscriber
Oladon wrote:

Huh! Nice find, PDK — that's a weird bug, but with the information you've provided it should be relatively easy to fix.

Thanks for your help!

Also thanks from me @ PDK for finding it, I was wondering why they stopped working 4 days ago.

@olandon, given the current times I was not sure wat your timeline for easy to fix was, but it is still out there for me.


Appreciate the reminder, Kulko. Should be able to get a fix out in the next week or two.


1 person marked this as a favorite.

Version 2.7.1

The Good

Figured out the issue with campaigns that are missing Gameplay threads, and fixed it. The Firefox version should be out shortly. The Chrome version may take a while longer.

The Bad

I initially made a mistake in the Chrome version, and submitted it for publishing... and Chrome won't let me change it once it's "under review". Sooooo... it might break for Chrome users if they approve it, and until I can release version 2.7.2 to fix the issue. (Incidentally, that probably also means I'll skip 2.7.2 on Firefox to synchronize the two again.)

I'll try to keep an eye on it and submit the fixed version as soon as they either reject or approve the current one, so hopefully it won't be broken for long.


Thanks Oladon!


Chrome News

The Good

They rejected 2.7.1 quickly — yay!

The Bad

They rejected it for "violating their policies" by " [having a] blank description field, or missing icons or screenshots, and appear[ing] to be suspicious".

Sigh...

So, first things first... anyone feel like taking a crack at making an "icon" for the extension? Google's never complained about it not having an icon before, but they are now.


Here you have a quick attempt with properly sized Pathfinder Tools logos.

I hope that helps.


Thanks, Balacertar!

Are these original by you, or if not, what's the license on them?


It's all based on the community use materials. If you worry about licenses I can make something simpler with no aesthetic connection to Pathfinder but license-free.


2 people marked this as a favorite.

Ok, I uploaded a new version.

Simpler but completely free of license burdens.

The sword is Creative Commons licensed. The rest is HTML I edited using the boards CSS style and I release my work as Creative Commons too.


Thankee, Balacertar!


3 people marked this as a favorite.

Chrome News

Oh hey, they approved it with Balacertar's icon — three cheers for Balacertar!

Note that the version ended up being 2.7.1 instead of 2.7.2 as I posted above; they let me upload a new package with the same version. So both versions are synchronized at 2.7.1.


Ah what a shame.
With the new firefox 4 android, the add-on is no longer available.
@Oladon: Do you see any chance for a return on that new platform?


1 person marked this as a favorite.

It's not? Hrm... yeah, I can probably arrange for that. Might take a few weeks, but I'll see what I can do.

And of course if anyone else wants to take a crack at fixing it, contributions are very welcome!


Bad news...

Firefox for Android News

Unfortunately, it looks like this isn't something I can fix; Mozilla has actually removed compatibility with extensions such as this one in this release of Firefox for Android. According to Mozilla's blog, they don't have any definite plans to support this extension (or thousands of others) in the near future.

There are some non-mainstream browsers which enable extensions for mobile devices, but I don't know enough about them to actually recommend using them.


I feared as much.
Thanks for checking though.


It just seemed to break for me on Firefox (regular desktop version). Not sure why, it just isn't doing anything at all.


Hmm, it's working for me on your page... could you try going to your campaigns page and let me know whether you see it there?


Nope. That was the page I first noticed it had broken on. It's like it's not even installed (I tried disabling/re-enabling but it didn't do anything).


Very odd. Could you PM me your Firefox version and any other extensions you have installed, please?


It suddenly started working again, for... some reason.


Hurray! :P

Thanks for reporting back. :)

Liberty's Edge

Pathfinder Adventure Path, Rulebook, Starfinder Roleplaying Game Subscriber

Oladon, is the little icon appearing next to the GameMaster on my Campaigns page from your Campaign Tools? It doesn't show up on my phone, and I didn't see anything about it in Website Feedback.


No comment.


Hi there. Thanks very much for the Paizo Campaign Tools extension! I use it regularly, and I love it.

One minor issue that maybe someone knows how to resolve: I set a "Custom" campaign arrangement on my Campaigns tab, and it worked fine the first time I used it. One day, I decided to rearrange the campaigns, and I saved the new arrangement. Now, whenever my Campaigns page loads, it defaults to my original campaign arrangement, not my most recent saved arrangement. However, if I click the pencil/Edit icon, the boxes that indicate the campaigns can be dragged around appear, and they are automatically arranged in the most recently-saved order. When I click the edit button again, the campaigns stay in this arrangement, also.

It's a minor issue, but I'm assuming that this isn't how it's supposed to work. I'm assuming that the first campaign arrangement that should appear when I load the Campaigns page is my most recently save arrangement.


Sorry for the delayed response there, Andostre.

Hmm, that's odd indeed. Could you PM me with what browser and version of the extension you're using, so we can troubleshoot from there?

Thanks!


PM sent. As I explained in my PM, the error somehow resolved itself 4 or 5 weeks ago, but the minor inconvenience listed above had been going on before my post. At least since January.


Vurry strange indeed. Let me know if it recurs...

351 to 391 of 391 << first < prev | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | next > last >>
Community / Forums / Online Campaigns / General Discussion / Paizo Forum Tools (Firefox / Chrome Browser Extension) All Messageboards

Want to post a reply? Sign in.
Recent threads in General Discussion