Unable to Log In Yesterday


Website Feedback


Tried multiple times, as did my players, to log in to no avail yesterday.

Today I tried to open a link at the bottom of a thread about 2 minutes after opening it and got this message:

"You have made too many requests for the same page too quickly.

Please wait a minute before trying again."

<blink>


The website has been a nightmare for about the last three weeks or so.

Paizo needs to invest a bit more in its website upkeep, seems to me.


They just switched ISPs last week.

Liberty's Edge

Hopefully it's just upgrade complications as they work behind the scenes on the site and in anticipation of Game Space.

Digital Products Assistant

We had an unexpected issue yesterday where our Internet connection went down and did not return until late last night. This may have caused intermittent issues when attempting to contact paizo.com. If you experience further oddities when attempting to log in/access paizo.com, please let us know.

Liberty's Edge

We will, thanks for everything

Paizo Employee PostMonster General

5 people marked this as a favorite.

We've recently added a new webpage that we are trying to keep updated when we're having downtime: status.paizo.com

If paizo.com won't load for you, that page should tell you if we're doing maintenance or having ISP problems or whatever. It's not hosted with the rest of the website so it should work even if paizo.com itself is down.


Hi Gary.

Not sure if this is related or not, but since the most recent downtime I havent been able to open any of the subforums, although I can see the whole list of them okay. (I couldnt open Website Feedback to make a new thread about this, for example).

Obviously, I can post in those half-dozen threads I can see okay, but viewing anything more nuanced than paizo/messageboards just produces a little spinning circle forever and doesnt show me any threads, nor the 'make new thread' button and so forth.

Paizo Employee Chief Technical Officer

Steve, I think you're in the same boat as these folks.

Liberty's Edge

1 person marked this as a favorite.

In the past few days, there were times when the site was unable to load. However, I know that moving to a new ISP is not easy.

The Paizo Blog is taking a very long time to load.

Paizo Employee Chief Technical Officer

William Ronald wrote:
The Paizo Blog is taking a very long time to load.

Yeah, it's a 5 MB page, with a number of embedded videos... even though you don't see those until you click to read those articles. We need to change that...

Liberty's Edge

Vic Wertz wrote:
William Ronald wrote:
The Paizo Blog is taking a very long time to load.
Yeah, it's a 5 MB page, with a number of embedded videos... even though you don't see those until you click to read those articles. We need to change that...

I have faith that everything will be well, soon. You and the rest of the Paizo team do a great job here.

The Exchange

Vic Wertz wrote:
William Ronald wrote:
The Paizo Blog is taking a very long time to load.
Yeah, it's a 5 MB page, with a number of embedded videos... even though you don't see those until you click to read those articles. We need to change that...

Paizo blog loads just fine for me - still cannot get into the sub-forums except through my work computer (for some reason).

Community / Forums / Paizo / Website Feedback / Unable to Log In Yesterday All Messageboards

Want to post a reply? Sign in.